View unanswered posts | View active topics It is currently 17 Oct 2018 21:37

Forum rules


- Use common sense and be respectful towards each other at all times, even when disagreeing.
- Do not reveal sensitive game information. Guild secrets, player seconds are examples of things not allowed.



Reply to topic  [ 5 posts ] 
Can't save trigger in web client? 
Author Message
Greenhorne

Joined: 10 May 2017 16:48
Posts: 5
I can't seem to find any other complaints on this, so I wonder if I am missing something obvious, but here goes:

I connect using the web client in Chrome browser on windows 10. I can create aliases fine, but when I try to create a trigger the save button does not work:

-Login in with my character
-Click Settings -> Triggers -> Add new trigger
-type trigger name (eg: loot)
-type command (eg: get all from corpse)
-Click Save

Nothing happens, the button highlights blue, but that's it. I tried on a brand new windows PC and in Microsoft Edge browser as well, but same issue. Note that all other fields are left at default, including the pre-populated Pattern of "You killed"

Anyone know what is going on? Do I need a different Javascript setting or updated Java version or something?

Thank you!


15 Jul 2017 22:26
Profile
Adventurer
User avatar

Joined: 18 May 2017 16:22
Posts: 98
Location: Sipping on some joe in the necro lounge
I will try to help and the only thing I can think of doing is telling you how I do it.

-Trigger Name
[grind all]

-Trigger Type
[Text][Regexp][GMCP] [CASE SENSITIVE]

-Pattern
[You killed]

-Script Type
[Commands][Javascript]
1| get all from corpse


So this is a mock up of my data entry when I set up a trigger (same as your loot trigger), a very basic one to make grinding easier. I hope it helps. haha

Legend:
Red is the selected Script type, Trigger type.

I have used Chrome as well and it gave me no problem. I wish you luck.


15 Jul 2017 22:38
Profile
Greenhorne

Joined: 10 May 2017 16:48
Posts: 5
I took a look at the console in my web browser, and found that there is an error. I attached a screenshot. Apparently it can't access my userdata.json file... ??!!


Attachments:
Web Client Error.JPG
Web Client Error.JPG [ 52.75 KiB | Viewed 944 times ]
16 Jul 2017 04:29
Profile
Greenhorne

Joined: 10 May 2017 16:48
Posts: 5
In case anyone else runs into this (which at least one other person I talked to has), the problem
was using the Pattern field default of value of "You killed" will, for some reason, cause the trigger not to save.
The default value can't be deleted with backspace or delete key, but must simply be overwritten with new text.
It can be exactly the same as the default text, if desired.

Now, onto figuring out how to effectively use the triggers :)


03 Aug 2017 18:58
Profile
Adventurer

Joined: 18 Jul 2017 19:31
Posts: 82
kelrhys wrote:
In case anyone else runs into this (which at least one other person I talked to has), the problem
was using the Pattern field default of value of "You killed" will, for some reason, cause the trigger not to save.
The default value can't be deleted with backspace or delete key, but must simply be overwritten with new text.
It can be exactly the same as the default text, if desired.

thank you!! I was having the same problem and this did the trick


03 Aug 2017 19:11
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.