Apostrophe in Trigger Patterns

Report bugs and suggest new features for the web client here.

Moderator: Eowul

Forum rules
- Use common sense and be respectful towards each other at all times, even when disagreeing.
- Do not reveal sensitive game information. Guild secrets, player seconds are examples of things not allowed.
Post Reply
User avatar
Shanoga
Wizard
Posts: 166
Joined: 03 Mar 2014 13:03
Location: US West

Apostrophe in Trigger Patterns

Post by Shanoga » 24 Jul 2018 23:20

I was helping Rangar out with a trigger to do some color-coding in the webclient and we ran into quite an issue. After a week of trying to fix it by proxy via mobile, I finally hopped on and figured out what was the problem....

When attempting to capture an apostrophe from the client, it has to be captured as the HTML code:

Code: Select all

'
Needless to say, this led to some frustration before we figured it out. Keep in mind, this is the case only for apostrophes as far as I can tell (commas, question marks, periods, exclamation points, and colons for sure operate normally), but it does impacyt Regexp patterns and Text patterns. This has to mean that somewhere the browser is translating the apostrophe to the HTML code above.

I would assumed this is a webclient issue, but I'm not sure.

Rangar
Beginner
Posts: 16
Joined: 15 Dec 2012 23:07
Location: Poland

Re: Apostrophe in Trigger Patterns

Post by Rangar » 25 Jul 2018 08:50

Thank you for your input, Shanoga - I really appreciate it. I have yet to find a nicer and more helpful coder, both on Genesis and in RL ;)

Post Reply
http://tworzymyatmosfere.pl/przescieradla-jedwabne-z-gumka/